Scheduled Trigger Degraded Performance

Incident Report for Tray.ai

Resolved

This incident has now been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.ai.

Thank you for your patience and understanding.
Posted Jul 02, 2026 - 09:51 BST

Monitoring

The fix for the scheduled trigger issue has now taken effect, and all delayed workflow executions have caught up. Our systems have been operating normally since 7:50 AM UTC. We are continuing to monitor the situation closely to ensure stability.
Posted Jul 02, 2026 - 09:11 BST

Identified

We have identified the issue causing scheduled triggers not to fire, impacting workflow execution in the US region. Our team is currently applying a fix and monitoring the results closely. We will provide further updates as more information becomes available.
Posted Jul 02, 2026 - 09:09 BST

Investigating

Starting 7:00 AM UTC on Thursday, July 2, 2026, some customers in the US region may be experiencing issues with scheduled triggers not firing, which is impacting workflow execution. Our team is currently investigating the root cause and working towards a resolution.

We will provide further updates as more information becomes available. We apologise for any inconvenience this may cause.

If you have any questions or concerns, please feel free to reach out to support@tray.ai. Thank you for your patience and understanding.
Posted Jul 02, 2026 - 09:06 BST
This incident affected: Workflow Execution.