Degraded Application Performance

Incident Report for Tray.ai

Resolved

On July 13, 2026, from 15:20 to 19:36 UTC, Gmail authentications within the US region may have encountered token refresh retries that eventually succeeded. The impact was isolated to two customers and we have reached out to those customers. If you did not receive a message related to this incident, your organization should not have been affected.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.ai.

Thank you for your patience and understanding.
Posted Jul 13, 2026 - 23:32 BST

Identified

During the investigation, we isolated the impact couple of customers and reached out to those customers. If you did not receive a message from us related to this incident, it is highly unlikely that your organization was impacted by this incident.

We have a identified the potential cause and are continuing to investigate. We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.ai.

Thank you for your patience and understanding.
Posted Jul 13, 2026 - 22:55 BST

Update

Our engineering teams are continuing to investigate this incident. We will be back with more information as soon as possible. We are very sorry for any inconvenience this incident may cause.
Posted Jul 13, 2026 - 22:01 BST

Investigating

On July 13, 2026, starting at 15:20 UTC, Gmail authentications within the US region may encounter retries when refreshing the token, but should eventually succeed.

We are currently investigating. Thank you for your patience and understanding.

If you have any questions or concerns, please feel free to reach out to support@tray.ai.
Posted Jul 13, 2026 - 20:39 BST
This incident affected: Connectors (Other).