Degraded Application Performance - Project Versions

Incident Report for Tray.ai

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 17:13 BST

Investigating

Users may be experiencing issues related to project versions across all regions.

Our engineering team is currently investigating the issue and working toward a resolution.

We apologise for any inconvenience this incident may have caused.
Posted Jun 18, 2026 - 17:12 BST
This incident affected: Workflow Execution and Insights, Usage and Logs.