Degraded Application Performance in EU

Incident Report for Tray.ai

Resolved

Workflow executions on the EU platform may have experienced some degraded performance between 14:22 GMT and 14:56 GMT. This incident has been resolved, and all our systems are operational.
Posted Mar 11, 2025 - 14:55 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 14:45 GMT

Investigating

Our engineering teams are continuing to investigate this incident. We will be back with more information as soon as possible. We are very sorry for any inconvenience this incident may cause.
Posted Mar 11, 2025 - 14:22 GMT
This incident affected: Workflow Execution.