Degraded Application Performance

Incident Report for Tray.ai

Resolved

This incident has been resolved.
Posted May 08, 2026 - 18:00 BST

Investigating

Starting at 16:15 UTC on Friday, May 8th, 2026, users may have experienced workflow failures involving Script connectors version 3.3 in the US region.

Our engineering team is actively investigating the issue.

We apologise for any inconvenience this incident may have caused.

If you have any questions or concerns, please feel free to reach out to support@tray.ai.
Posted May 08, 2026 - 16:15 BST
This incident affected: Workflow Execution, Workflow Triggers and Connectors (Other).