The scheduled maintenance has been completed for all regions.
If you have any questions or concerns, please feel free to reach out to support@tray.ai. Thank you for your patience and understanding.
Posted Nov 10, 2025 - 11:48 GMT
Update
Verification is currently underway for the AP region.
Posted Nov 10, 2025 - 11:40 GMT
Update
Verification for the US region is complete and the maintenance is complete for the US region.
Posted Nov 10, 2025 - 11:30 GMT
Update
Verification for the EU region is complete and the maintenance is complete for the EU region.
Posted Nov 10, 2025 - 11:22 GMT
Update
Verification is currently underway for the US region.
Posted Nov 10, 2025 - 11:15 GMT
Verifying
Verification is currently underway for the EU region.
Posted Nov 10, 2025 - 10:53 GMT
Update
Scheduled maintenance is currently in progress for the AP region. We will provide updates as necessary.
Posted Nov 10, 2025 - 09:33 GMT
Update
Scheduled maintenance is currently in progress for the EU region. We will provide updates as necessary.
Posted Nov 10, 2025 - 09:14 GMT
In progress
Scheduled maintenance is currently in progress for the US region. We will provide updates as necessary.
Posted Nov 10, 2025 - 08:00 GMT
Update
We will be undergoing maintenance in 10 minutes
Posted Nov 10, 2025 - 07:50 GMT
Scheduled
On Monday, 10th of November 2025, we will be performing an essential upgrade on the CSV-Editor databases across all regions.
The maintenance window will be between 08:00 and 12:00 UTC (10th November 00:00 PST to 10th November 04:00 PST, 10th November 19:00 AEDT to 10th November 23:00 AEDT).
During this period, any users with "account" scopes for the CSV-Editor connector will experience delays to their executions. Please note that this will only delay these specific CSV write operations, but they will not fail.
All "current run" scopes CSV-Editor operations and read operations on "account" scopes for CSV-Editor will remain unaffected.
If you have any questions, or would like to get in touch about anything at all, please drop us a line at support@tray.ai.
Posted Oct 29, 2025 - 22:23 GMT
This scheduled maintenance affected: Connectors (CSV Editor).