Verification is currently underway for the maintenance items.
Posted Jul 21, 2025 - 09:33 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2025 - 09:00 BST
Update
We will be undergoing scheduled maintenance in 5 minutes.
Posted Jul 21, 2025 - 08:55 BST
Scheduled
On Monday, 21st July 2025, we will be upgrading on one of our databases in the US region.
The maintenance window is scheduled for 09:00 to 10:00 BST (01:00 to 02:00 PDT). During the window there will be ~10 minutes of time where there will be delays processing workflow trigger updates whilst the upgrade happens. Running of workflow executions will continue as normal and not be impacted.
If you have any questions, or would like to get in touch about anything at all, please drop us a line at support@tray.ai.
Posted Jul 14, 2025 - 03:03 BST
This scheduled maintenance affected: Workflow Triggers.