Overall Platform Outage
Incident Report for Tray.ai
Resolved
This incident has been resolved and all our systems are operational.

Between 11:18am BST to 11:29am BST customers in the US, EU, and APAC regions experienced difficulties logging into the application. Additionally, Tray's Public API encountered errors during this period, customers may have also encountered errors with execution which would have resulted them showing as failed within the execution logs.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted May 28, 2024 - 12:44 BST
Monitoring
Our engineers have identified the issue and implemented a fix for the issue.

We apologise for any inconvenience this incident may cause. If you have any questions or concerns, please reach out to us at support@tray.io.
Posted May 28, 2024 - 11:37 BST
Investigating
Our engineers are currently investigating an issue affecting Tray services across US, EU and APAC.
Posted May 28, 2024 - 11:29 BST
This incident affected: Workflow Execution, Workflow Builder (Workflow Builder API, Workflow Builder App, Workflow Builder Logs), Embedded (Embedded API, Embedded App), and Connectivity API (Connectors API, Triggers API).