Degraded Application Performance - Gmail Trigger EU

Incident Report for Tray.ai

Resolved

This incident has been resolved and all our systems are operational.

We apologize for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.ai.

Thank you for your patience and understanding.
Posted Jun 12, 2025 - 20:22 BST

Investigating

Beginning at 18:11 GMT, users may have begun experiencing issues with the Gmail trigger. Customers on the EU server may have had difficulties logging in to the Tray application as well. We are currently investigating the source and will continue to update here. We apologize for any inconvenience this incident may cause. If you have any questions or concerns, please feel free to reach out to support@tray.ai.
Posted Jun 12, 2025 - 19:27 BST
This incident affected: Workflow Execution and Workflow Triggers.