Degraded Application Performance
Incident Report for Tray.ai
Resolved
This incident has been resolved and all our systems are operational. US Customers may have experienced delays when enabling a new workflow or changing the trigger of an existing workflow for US instances between 18:00 and 21:16 GMT. Workflows should eventually enable or reflect changes after the delay.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.ai.

Thank you for your patience and understanding.
Posted Nov 08, 2024 - 21:19 GMT
Investigating
Customers may experience delays when enabling a new workflow or changing the trigger of an existing workflow for US instances starting at 18:00 GMT. Workflows should eventually enable or reflect changes after a delay.

We are currently investigating an issue that is causing unexpected behaviours within the Tray application. If you have any questions or concerns, please feel free to reach out to support@tray.ai.
Posted Nov 08, 2024 - 20:37 GMT
This incident affected: Workflow Builder (Workflow Builder App).