This incident has been resolved, and all our systems are operational.
During this incident, short delays in workflow triggers were experienced from 6pm UTC to 6:54pm UTC in the US region.
Thank you for your understanding and cooperation during this brief disruption. We appreciate your continued support as we strive to maintain the highest standards of service.
If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Aug 23, 2024 - 20:14 BST
Update
We are continuing to investigate the issue which is causing delays in workflow triggers specifically.
Posted Aug 23, 2024 - 20:07 BST
Investigating
We are currently investigating an issue causing delays in workflow executions.
We apologise for any inconvenience this incident may cause. If you have any questions or concerns, please reach out to us at support@tray.io.