Degraded Application Performance in EU and APAC

Incident Report for Tray.ai

Resolved

This incident has been successfully resolved, and our systems are now fully operational. While the issue did impact the creation of new authentications, refreshes continued to function as expected.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Sep 20, 2023 - 12:31 BST

Monitoring

Our engineering teams have applied a fix and are currently monitoring the results.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Sep 20, 2023 - 12:10 BST

Identified

Our engineering teams have identified the issue and are now working on a fix. We will be back with a new update shortly.

Thank you for your patience and understanding.
Posted Sep 20, 2023 - 11:42 BST

Investigating

We are currently investigating an issue that is impacting user authentications within the Tray application in the EU and APAC regions.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Sep 20, 2023 - 11:29 BST
This incident affected: Workflow Execution and Connectivity API (Connectors API).