Issues Logging into Tray Application

Incident Report for Tray.ai

Resolved

This incident has been resolved and login is now working as expected. Thank you for your patience.

If you have any further questions, please feel free to reach out to support@tray.ai.
Posted Jul 16, 2026 - 15:49 BST

Monitoring

We've applied a fix and login should now be working as expected. We're monitoring the situation closely to ensure the issue is fully resolved.

We apologise for any inconvenience. If you have any questions in the meantime, please feel free to reach out to support@tray.ai.
Posted Jul 16, 2026 - 15:33 BST

Update

Our engineering team is continuing to work on a fix.

In the meantime, affected users can log in via the alternative login page for their region as a workaround:
US: https://app.tray.io/v2/login
EU: https://app.eu1.tray.io/v2/login
AP: https://app.ap1.tray.io/v2/login

We apologise for any inconvenience. If you have any questions in the meantime, please feel free to reach out to support@tray.ai.
Posted Jul 16, 2026 - 14:48 BST

Identified

We've identified the cause of the issue. Our engineering team is working on a fix and we'll provide a further update shortly.

We apologise for any inconvenience. If you have any questions in the meantime, please feel free to reach out to support@tray.ai.
Posted Jul 16, 2026 - 13:28 BST

Investigating

We're currently investigating an issue affecting login for users logging in via email verification. Our engineering team is looking into it and working to restore normal service as quickly as possible.

We apologise for any inconvenience. If you have any questions in the meantime, please feel free to reach out to support@tray.ai.
Posted Jul 16, 2026 - 13:06 BST
This incident affected: Workflow Builder (Workflow Builder App).