Degraded Performance of Workflow Executions
Incident Report for Tray.ai
Resolved
This incident has been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted May 22, 2024 - 11:59 BST
Update
All workflow executions are now running as expected, and customers should no longer experience throttling in their data storage steps.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please reach out to us at support@tray.io.
Posted May 22, 2024 - 11:49 BST
Monitoring
Our engineers have applied a fix and workflow executions are now running as expected. However, some customers may see their data storage steps to be throttled.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please reach out to us at support@tray.io.
Posted May 22, 2024 - 11:16 BST
Investigating
We are currently investigating an issue causing delays in workflow executions. Additionally, users may experience retries in Data Storage steps that are configured to use the account scope.

We apologise for any inconvenience this incident may cause. If you have any questions or concerns, please reach out to us at support@tray.io.
Posted May 22, 2024 - 10:43 BST
This incident affected: Workflow Execution.